If you have such a problem ERROR: Your Java is not a derivative from Sun's code when starting FreePlane (or FreeMind), correct your java with the command :

/usr/sbin/update-alternatives --config java